Cocktail Audio™ UK Support Forum
http://cocktailaudio.co.uk/Forum/

New Firmware Update - Query Error! (How to fix it)
http://cocktailaudio.co.uk/Forum/viewtopic.php?f=23&t=1227
Page 1 of 2

Author:  daverock [ Tue Dec 16, 2014 7:06 pm ]
Post subject:  New Firmware Update - Query Error! (How to fix it)

Evening,
I have just downloaded the latest firmware update and I get "Query Error!" when I go to my music database.

I tried a recovery and see from the recovery result that all my music has been moved! I'm jusr not sure where it's been moved to or how to un-move it so that I can play it!

Any ideas folks?

Cheers,
Dave

Author:  stane [ Tue Dec 16, 2014 8:16 pm ]
Post subject:  Re: New Firmware update

I think these are the solution:

X10:: viewtopic.php?f=23&t=1026&start=50&hilit=irregular


For X30:: viewtopic.php?f=23&t=1025&p=6522&hilit=irregular#p6522

Author:  Admin [ Tue Dec 16, 2014 8:20 pm ]
Post subject:  Re: New Firmware update - Query Error!

It's the structural changes but the DB got corrupted during your update.
You need to reinstall r1692 & then r1793 ...to fix it!

Author:  daverock [ Tue Dec 16, 2014 9:19 pm ]
Post subject:  Re: New Firmware update - Query Error!

Thanks folks.
I've done that and can now see my music in the database. The problem now is that it wont play!
My internet radio is playing fine but my music in the DB wont play!

Author:  Admin [ Tue Dec 16, 2014 9:56 pm ]
Post subject:  Re: New Firmware update - Query Error!

Yes, if you read the link above, you need to scan & remove the broken links (That is why you can't play any tracks).
1. Run the recovery* - to remove the broken links (songs will be moved to the HDD/Recovery or are already there...)
2. Move them back from the recovery folder (HDD/Recovery) - Menu/"import to DB" - after the recovery scan


[Setup/Music DB/Recovery*]

Author:  FabFreeq [ Tue Dec 16, 2014 10:49 pm ]
Post subject:  Re: New Firmware update - Query Error!

daverock wrote:
Thanks folks.
I've done that and can now see my music in the database. The problem now is that it wont play!
My internet radio is playing fine but my music in the DB wont play!


daverock......surely you're not expecting to play music on your x10! Oh no no that would be to simple.

Author:  Barry [ Mon Sep 04, 2017 11:22 pm ]
Post subject:  Re: New Firmware Update - Query Error! (How to fix it)

I have also run into this problem today after doing a firmware update on my X10 (for the first time). I tried the 1803 and then the 1795, both from a USB stick.

I see references to using earlier FWs such as 1692, but can someone kindly tell me where I might find these, as I only see only the two 1803 and 1795 FW downloads available on the website?

Author:  Moderator [ Tue Sep 05, 2017 4:44 pm ]
Post subject:  Re: New Firmware Update - Query Error! (How to fix it)

Assuming it isn't your HDD, then you could fix the problem with 1692 & 1805 or 1692 & 179X

Get the 1692 from here:
Download link
https://we.tl/muQsjr3ht3

Thank you,

Author:  Barry [ Tue Sep 05, 2017 7:33 pm ]
Post subject:  Re: New Firmware Update - Query Error! (How to fix it)

Thank you very much. I'm away from my X10 at the moment but will try the 1692 in the morning. I'm downloading it now.

I don't think it'll be the HDD as the unit was fine until I did the firmware upgrade, but who knows.

Author:  Barry [ Wed Sep 06, 2017 1:50 pm ]
Post subject:  Re: New Firmware Update - Query Error! (How to fix it)

Thank you for that link; having installed 1692 I no longer get the query error and the music DB appears as it should. Like the poster above, though, nothing now seems to play. The selected track appears to play normally, but there's no sound. I tried a few random albums and always got the same silence.

I've run a recovery, and there appear to be only a few albums (out of several hundred on the DB) moved into the recover folder. Any tips?

Page 1 of 2 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/